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FLOW OF SESSION
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Day 1

1. Microsoft Excel Fundamentals

2. Entering and Editing Text & Formulas

3. Working with Basics Excel Functions

4. Modifying an Excel Worksheet

5. Formatting Data in an Excel Worksheet

6. Inserting Images & Shapes into an Excel Worksheet

7. Creating Charts

8. Printing an Excel Worksheets

9. Excel Templates

Day 2

1. Working with an Excel List

2. Excel List Functions

3. Excel Data Validations

4. Importing and Exporting Data

5. Excel Pivot Tables

6. Working with Large Sets of Excel Data

FLOW OF SESSION
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MICROSOFT EXCEL FUNDAMENTALS
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EXCEL START-UP SCREEN
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Main 
Menu Blank 

Workbook Templates

Recent Documents

Other 
Menu



EXCEL INTERFACE
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Quick Access Toolbar

Ribbons
Name Bar Formula Bar

WorkSheets Tab
Status Bar

Workbook Area



COMMON EXCEL SHORTCUT KEYS
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To do this Press
Close a spreadsheet Ctrl+W
Open a spreadsheet Ctrl+O
Go to the Home tab Alt+H
Save a spreadsheet Ctrl+S
Copy Ctrl+C
Paste Ctrl+V
Undo Ctrl+Z
Remove cell contents Delete key
Choose a fill color Alt+H, H
Cut Ctrl+X
Go to Insert tab Alt+N
Bold Ctrl+B
Center align cell contents Alt+H, A, then C
Go to Page Layout tab Alt+P
Go to Data tab Alt+A
Go to View tab Alt+W
Open context menu Shift+F10, or

Context key
Add borders Alt+H, B
Delete column Alt+H,D, then C
Go to Formula tab Alt+M
Hide the selected rows Ctrl+9
Hide the selected columns Ctrl+0
Move to the previous cell in a worksheet or the 
previous option in a dialog box.

Shift+Tab

Move one cell up in a worksheet. Up Arrow key

To do this Press
Move one cell down in a worksheet. Down Arrow key
Move one cell left in a worksheet. Left Arrow key
Move one cell right in a worksheet. Right Arrow key
Move to the edge of the current data region in a 
worksheet.

Ctrl+arrow key

Enter End mode, move to the next nonblank cell 
in the same column or row as the active cell, 
and turn off End mode. If the cells are blank, 
move to the last cell in the row or column.

End, arrow key

Move to the last cell on a worksheet, to the 
lowest used row of the rightmost used column.

Ctrl+End

Extend the selection of cells to the last used cell 
on the worksheet (lower-right corner).

Ctrl+Shift+End

Move to the cell in the upper-left corner of the 
window when Scroll Lock is turned on.

Home+Scroll Lock

Move to the beginning of a worksheet. Ctrl+Home
Move one screen down in a worksheet. Page Down
Move to the next sheet in a workbook. Ctrl+Page Down
Move one screen to the right in a worksheet. Alt+Page Down
Move one screen up in a worksheet. Page Up
Move one screen to the left in a worksheet. Alt+Page Up
Move to the previous sheet in a workbook. Ctrl+Page Up
Move one cell to the right in a worksheet. Or, in 
a protected worksheet, move between unlocked 
cells.

Tab



ENTERING AND EDITING TEXT & FORMULAS
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WORKING WITH NUMBERS & TEXT & DATE
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▪ Numbers are aligned on Right
▪ Texts are aligned to the Left
▪ Any number with Text is identified 

as a text by excel
▪ Month with year is considered as 

date, only month name is 
identified as text by excel



▪ A cell reference refers to a cell or a range of cells on a worksheet and can be used in a 
formula so that Microsoft Office Excel can find the values or data that you want that 
formula to calculate.

▪ Referencing a Cell means referring to the Cell name in a formula.

▪ Cell name is written by using Column alphabet as 1st Character and Row Number after 
it.

• Eg. A1, B507, C10

▪ A single cell or multiple cells can be referenced.
• Eg. A1:B107, C10:F709

▪ Multiple cells together is called a Range

CELL REFERENCING IN EXCEL
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1. Functions: The PI() function returns the value of pi: 3.142...

2. References: A2 returns the value in cell A2.

3. Constants: Numbers or text values entered directly into a formula, such as 2.

4. Operators: The ^ (caret) operator raises a number to a power, and the * (asterisk) operator 
multiplies numbers.

EXCEL FORMULA STRUCTURE

A formula can also contain any or all of the 
following: functions, references, operators, 

and constants.

Parts of a formula
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https://support.microsoft.com/en-us/office/pi-function-264199d0-a3ba-46b8-975a-c4a04608989b


▪ By default, a cell reference is a relative reference, which means that the reference is relative to 
the location of the cell. If, for example, you refer to cell A2 from cell C2, you are actually referring 
to a cell that is two columns to the left (C minus A)—in the same row (2). When you copy a 
formula that contains a relative cell reference, that reference in the formula will change.

▪ As an example, if you copy the formula =B4*C4 from cell D4 to D5, the formula in D5 adjusts to the right by one 
column and becomes =B5*C5. If you want to maintain the original cell reference in this example when you copy 
it, you make the cell reference absolute by preceding the columns (B and C) and row (2) with a dollar sign ($). 
Then, when you copy the formula =$B$4*$C$4 from D4 to D5, the formula stays exactly the same.

RELATIVE VERSUS ABSOLUTE CELL REFERENCES IN FORMULAS
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▪ The table below summarizes how a reference type updates if a formula 
containing the reference is copied two cells down and two cells to the right.

HOW REFERENCES UPDATE
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▪ The elements to be calculated (the operands, such as numbers or cell references), are separated 
by calculation operators (such as +, -, *, or /). 

▪ Excel calculates the formula from left to right, according to a specific order for each operator in 
the formula.

▪ If you combine several operators in a single formula, Excel performs the operations in the order 
shown in the following table.

UNDERSTANDING ORDER OF OPERATION
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: (colon)
(single space)
, (comma)

Reference operators

– Negation (as in –1)

% Percent

^ Exponentiation (raising to a power)

* and / Multiplication and division

+ and – Addition and subtraction

& Connects two strings of text (concatenation)

=
< >
<=
>=
<>

Comparison



BASIC EXCEL FUNCTIONS
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1. Structure. The structure of a function begins with an equal sign (=), followed by the function 
name, an opening parenthesis, the arguments for the function separated by commas, and a 
closing parenthesis.

2. Function name.

3. Arguments. Arguments can be numbers, text, logical values such as TRUE or FALSE, arrays, error 
values such as #N/A, or cell references. The argument you designate must produce a valid value 
for that argument. Arguments can also be constants, formulas, or other functions.

4. Argument tooltip. A tooltip with the syntax and arguments appears as you type the function.

EXCEL FUNCTION STRUCTURE
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Functions are predefined formulas that perform
calculations by using specific values, called
arguments, in a particular order, or structure.
Functions can be used to perform simple or
complex calculations. You can find all of Excel's
functions on the Formulas tab on the Ribbon.

Excel function syntax



▪ Count

▪ Sum

▪ Average

▪ Max-Min

LIST OF COMMONLY USED FUNCTIONS IN EXCEL

17



SUM: The SUM function adds values. You can add individual values, cell references or ranges or a mix 

of all three.

Syntax – SUM(number1,[number2],...) - Up to 255 Arguments

SUMIF: Use the SUMIF function to sum the values in a range that meet criteria that you specify.

Syntax – SUMIF(range, criteria, [sum_range])

SUMIFS: The SUMIFS function adds all of its arguments that meet multiple criteria.

Syntax – SUMIFS(sum_range, criteria_range1, criteria1, [criteria_range2, criteria2], ...)

- Up to 127 range/criteria pairs

SUM FUNCTIONS
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COUNT: The COUNT function counts the number of cells that contain numbers, and counts numbers 

within the list of arguments.

Syntax – COUNT(value1, [value2], ...) - Up to 255 Arguments

COUNTIF: Use COUNTIF, to count the number of cells that meet a criterion.

Syntax – COUNTIF(range, criteria)

COUNTIFS: The COUNTIFS function applies criteria to cells across multiple ranges and counts the number 

of times all criteria are met.

Syntax – COUNTIFS(criteria_range1, criteria1, [criteria_range2, criteria2]…)

- Up to 127 range/criteria pairs

COUNT FUNCTIONS
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AVERAGE: Returns the average (arithmetic mean) of the arguments.

Syntax – AVERAGE(number1, [number2], ...) - Up to 255 Arguments

AVERAGEIF: Returns the average (arithmetic mean) of all the cells in a range that meet a given 

criteria.

Syntax – AVERAGEIF(range, criteria, [average_range])

AVERAGEIFS: Returns the average (arithmetic mean) of all cells that meet multiple criteria.

Syntax – AVERAGEIFS(average_range, criteria_range1, criteria1, [criteria_range2, criteria2], ...)

- Up to 127 range/criteria pairs

AVERAGE FUNCTIONS

20



Max / Min: Return the minimum or maximum of a set of values contained in a specified field on a query.

Syntax – Max( expr )

Min( expr )

MAXIFS: The MAXIFS function returns the maximum value among cells specified by a given set of 

conditions or criteria.

Syntax – MAXIFS(max_range, criteria_range1, criteria1, [criteria_range2, criteria2], ...)

- Up to 126 range/criteria pairs

MINIFS: The MINIFS function returns the minimum value among cells specified by a given set of conditions 

or criteria.

Syntax – MINIFS(min_range, criteria_range1, criteria1, [criteria_range2, criteria2], ...)

- Up to 126 range/criteria pairs

MAX – MIN FUNCTION
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▪ If you need to sum a column or row of numbers, let Excel do the 
math for you. Select a cell next to the numbers you want to sum, 
click AutoSum on the Home tab, press Enter, and you’re done.

▪ When you click AutoSum, Excel automatically enters a formula 
(that uses the SUM function) to sum the numbers.

▪ Here’s an example. To add the January numbers in this 
Entertainment budget, select cell B7, the cell immediately below 
the column of numbers. Then click AutoSum. A formula appears 
in cell B7, and Excel highlights the cells you’re totalling.

▪ Press Enter to display the result (95.94) in cell B7. You can also 
see the formula in the formula bar at the top of the Excel 
window.

AUTOSUM
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MODIFYING AN EXCEL WORKSHEET
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Insert or delete a column

▪ Select any cell within the column, then go to Home > Insert > Insert Sheet 
Columns or Delete Sheet Columns.

▪ Alternatively, right-click the top of the column, and then select Insert or Delete. 

Insert or delete a row

▪ Select any cell within the row, then go to Home > Insert > Insert Sheet Rows or 
Delete Sheet Rows.

▪ Alternatively, right-click the row number, and then select Insert or Delete.

INSERT OR DELETE ROWS AND COLUMNS
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Resize rows

▪ Select a row or a range of rows.

▪ On the Home tab, select Format > Row Width (or Row Height).

▪ Type the row width and select OK.

Resize columns

▪ Select a column or a range of columns.

▪ On the Home tab, select Format > Column Width (or Column Height).

▪ Type the column width and select OK.

Automatically resize all columns and rows to fit the data

▪ Select the Select All button Select All at the top of the worksheet,     to select all columns 
and rows.

▪ Double-click a boundary. All columns or rows resize to fit the data.

RESIZE ROWS & COLUMNS
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Hide columns

▪ Select one or more columns, and then press Ctrl to select additional columns that 
aren't adjacent.

▪ Right-click the selected columns, and then select Hide.

Note: The double line between two columns is an indicator that you've hidden a 
column.

Unhide columns

▪ Select the adjacent columns for the hidden columns.

▪ Right-click the selected columns, and then select Unhide.

▪ Or double-click the double line between the two columns where hidden columns 
exist.

HIDING AND UNHIDING EXCEL ROWS AND COLUMNS
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By default, Excel names worksheets Sheet1, Sheet2, Sheet3 and so on, but you can 
easily rename them.

3 ways to rename a worksheet

▪ Double-click the sheet tab, and type the new name.

▪ Right-click the sheet tab, click Rename, and type the new name.

▪ Use the keyboard shortcut Alt+H > O > R, and type the new name.

RENAMING AN EXCEL WORKSHEET
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Insert a worksheet

▪ Select the New Sheet plus icon Select      at the bottom of the workbook.

▪ Or select Home > Insert > Insert Sheet.

Rename a worksheet

▪ Double-click the sheet name on the Sheet tab to quickly rename it.

▪ Or right-click on the Sheet tab, click Rename, and type a new name.

Move a worksheet

▪ To move the tab to the end, right-click the Sheet tab then Move or Copy 
> (move to end) > OK .

▪ Or click and drag to tab to any spot.

Delete a worksheet

▪ Right-click the Sheet tab and select     Delete.

▪ Or select the sheet, and then select Home > Delete > Delete Sheet.

INSERT OR DELETE OR MOVE A WORKSHEET
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INSERTING IMAGES AND SHAPES INTO AN 
EXCEL WORKSHEET
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To insert a picture that is saved in a location you 
can access, follow these steps:

▪ Click the location in your worksheet where 
you want to insert a picture.

▪ On the Insert ribbon, click Pictures.

▪ Select This Device…

▪ Browse to the picture you want to insert, 
select it, and then click Open.

▪ The picture will be inserted in your 
worksheet.

INSERT A PICTURE IN EXCEL
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▪ On the Insert tab, click Shapes.

▪ Click the shape you want, click anywhere in the workspace, and then drag to 
place the shape.

▪ To create a perfect square or circle (or constrain the dimensions of other 
shapes), press and hold Shift while you drag.

▪ After you've added shapes to your document, spreadsheet, presentation, or 
email, make the shapes look exactly how you want.

▪ Select the shapes you want to format.

▪ Select Shape Fill to fill the selected shapes with a solid color, gradient, texture, 
or picture.

▪ Select Shape Outline to pick the color, width, or line style for your shape's 
border.

▪ Select Shape Effects to give your shapes a shadow, reflection, or glow.

▪ Select a Shape Style to apply a unique combination of colors, lines, and other 
effects that look great together.

▪ Tip: To select more than one, press and hold the Shift key.

ADD A SHAPE IN EXCEL & FORMAT SHAPES
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Insert a SmartArt graphic and add text to it

▪ On the Insert tab, in the Illustrations group, click 
SmartArt.

▪ In the Choose a SmartArt Graphic dialog box, click the 
type and layout that you want.

▪ Enter your text by doing one of the following:

• Click [Text] in the Text pane, and then type your 
text.

• Copy text from another location or program, click 
[Text] in the Text pane, and then paste your text.

• Notes: If the Text pane is not visible, click the 
arrow control on the left side of the SmartArt 
graphic.

• Click in a box in the SmartArt graphic, and then 
type your text. For best results, use this option 
after you add all of the boxes that you want.

EXCEL SMARTART
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CREATING BASIC CHARTS IN EXCEL
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To create a column chart, follow these steps:

▪ Enter data in a spreadsheet.

▪ Select the data.

▪ Click Insert > Insert Column or Bar Chart icon and select a column chart 
option of your choice.

To create a pie chart, follow these steps:

▪ In your spreadsheet, select the data to use for your pie chart.

▪ Click Insert > Insert Pie or Doughnut Chart, and then pick the chart you 
want.

▪ Click the chart and then click the icons next to the chart to add finishing 
touches:

▪ To show, hide, or format things like axis titles or data labels, click Chart 
Elements.

▪ To quickly change the color or style of the chart, use the Chart Styles.

▪ To show or hide data in your chart click Chart Filters.

▪ Pie chart with Chart Elements, Chart Styles, and Chart Filters buttons
• Tip: You can draw attention to individual slices of the pie chart by dragging them 

out

CREATING AN EXCEL COLUMN & PIE CHART
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You can optionally format the chart a little further. See the list below for a few options:

• Note: Make sure you click on the chart first before applying a formatting 
option.

▪ To apply a different chart layout, click Design > Charts Layout, and select a layout.

▪ To apply a different chart style, click Design > Chart Styles, and pick a style.

▪ To apply a different shape style, click Format > Shape Styles, and pick a style.

• Note: A chart style is different from a shape style. A shape style is a formatting 
option that applies to the chart’s border only, whereas the chart style is a 
formatting option that applies to the entire chart.

▪ To apply different shape effects, click Format > Shape Effects, and pick an option 
such as Bevel or Glow, and then a sub option.

▪ To apply a theme, click Page Layout > Themes, and select a theme.

▪ To apply a formatting option to a specific component of a chart (such as Vertical 
(Value) Axis, Horizontal (Category) Axis, Chart Area, to name a few), click Format > 
pick a component in the Chart Elements dropdown box, click Format Selection, and 
make any necessary changes. Repeat the step for each component you want to 
modify.

• Note: If you are comfortable working in charts, you can also select and right-
click on a specific area on the chart and select a formatting option.

FORMATTING A CHART
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PRINTING AN EXCEL WORKSHEET

36



Print one or several worksheets

▪ Select the worksheets that you want to print. 

▪ Select File > Print, or press CTRL+P.

▪ Select the Print button or adjust Settings before you select the Print 
button.

Print one or several workbooks

▪ All workbook files that you want to print must be in the same folder.

▪ Select File > Open.

▪ Hold down CTRL click the name of each workbook to print, and then 
select Print.

Print all or part of a worksheet

▪ Click the worksheet, and then select the range of data that you want 
to print.

▪ Select File, and then click Print.

▪ Under Settings, select the arrow next to Print Active Sheets and select 
the appropriate option.

▪ Select Print.

PRINT WORKBOOK & WORKSHEET
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THANK YOU
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